Picsart.io Incident
Postmortem

Summary

A high number of 502 response codes were detected by monitoring tests at 15:45 & an incident was reported.
The issue affected three of our services, both on demo & production environments. The services were the following:

  • Style transfer
  • Upscale
  • Remove Background

At 16:22 the reason was identified.
The incident had been resolved at 16:46 after a successful fix.

There was a problem while injecting secrets, which caused the downtime of the services.

Posted Apr 01, 2022 - 05:51 PDT

Resolved
The incident has been resolved, there was a problem while injecting secrets.
Posted Apr 01, 2022 - 04:46 PDT
Identified
The root cause has been identified, the team is now working on a fix.
Posted Apr 01, 2022 - 04:22 PDT
Investigating
We are experiencing issues with three of our services, Upscale, Style Transfer & Remove Background. The team is currently investigating the issue.
Posted Apr 01, 2022 - 03:54 PDT
This incident affected: Photo Enhancement (Upscale), Style Transfer (Style Transfer), and Remove Background (Remove Background).