Ongoing Incident — Instant Avatar

Incident Report for APIs Status - Picsart Enterprise

Resolved

The incident has been resolved.
Posted May 13, 2026 - 05:59 PDT

Investigating

We’re currently experiencing degraded performance issues with our Instant Avatar service. Our team is currently working to restore normal performance levels.
Posted May 13, 2026 - 05:36 PDT
This incident affected: Picsart Genai Avatar APIs (Instant Avatar).