Console Incident
Resolved
The incident has been successfully resolved.
Posted Jul 24, 2023 - 06:42 PDT
Investigating
We’re currently experiencing degraded performance issues with our Console (console.picsart.io). Our team is currently working to restore normal performance levels.
Posted Jul 24, 2023 - 05:34 PDT
This incident affected: Console.