Ongoing Incident — AI Services

Incident Report for APIs Status - Picsart Enterprise

Resolved

We are pleased to inform you that the incident has been resolved, and we are now fully operational
Posted Dec 04, 2025 - 10:17 PST

Update

We are continuing to investigate this issue.
Posted Dec 04, 2025 - 08:29 PST

Investigating

We are currently experiencing issues with our AI Services, causing temporary delays and disruptions in several tools.
Our teams are actively investigating and working to restore full functionality.
We will post updates here as the situation evolves.
Posted Dec 04, 2025 - 08:28 PST
This incident affected: Picsart Programmable Image APIs (Upscale, Ultra Enhance, Face Enhancement, Style Transfer, Texture Generator, AI Upscale & Enhancement Services) and Picsart Genai APIs (AI Painting Tools).