Remove Background Service Incident
Resolved
The incident has been successfully resolved.
Posted Feb 06, 2024 - 07:40 PST
Investigating
We’re currently experiencing degraded performance issues with our Remove Background Service. Our team is currently working to restore normal performance levels.
Posted Feb 06, 2024 - 06:50 PST
This incident affected: Remove Background (Remove Background).