Performance Degradation on Picsart.io
Incident Report for APIs Status - Picsart Enterprise
Resolved
Dear Users,

The performance degradation issue on Picsart.io has been resolved. The service is now fully restored. We apologize for the inconvenience and appreciate your patience.

Thank you for your continued support.
Posted Sep 11, 2024 - 12:17 PDT
Investigating
Dear Valued Users,

We want to inform you that we are currently experiencing performance degradation issues on Picsart.io. Our dedicated team of engineers is actively investigating the cause of this disruption, and we are working diligently to restore the service to its full capacity as quickly as possible.

We understand the critical role Picsart.io plays in your creative endeavors, and we sincerely apologize for any inconvenience this may cause. Please rest assured that resolving this issue is our top priority.

We will continue to provide real-time updates on our progress and will notify you as soon as the service is fully restored.

Thank you for your patience and understanding.
Posted Sep 11, 2024 - 10:10 PDT
This incident affected: Picsart.io.