Text2Text Incident

Incident Report for APIs Status - Picsart Enterprise

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 00:49 PDT

Update

We are continuing to investigate this issue.
Posted Oct 14, 2025 - 00:48 PDT

Investigating

We’re currently experiencing degraded performance issues with ourText2Text. Our team is currently working to restore normal performance levels.
Posted Oct 12, 2025 - 08:17 PDT
This incident affected: Picsart Genai APIs (Text2Text).