Console Incident

Incident Report for APIs Status - Picsart Enterprise

Resolved

The incident has been successfully resolved.
Posted Sep 22, 2023 - 05:25 PDT

Investigating

We’re currently experiencing degraded performance issues with our Console (console.picsart.io). Our team is currently working to restore normal performance levels.
Posted Sep 22, 2023 - 05:13 PDT
This incident affected: Console Picsart.io.